[Solved] Fails to install on Vista Premium.

Dec 14, 2007 at 8:32 PM
Hello and thanks for this project. :)

Unfortunately I fail to install IronPython Studio on my Vista Premium box where I'm admin.

I've installed Visual Studio Shell 2008 Isolated Mode Setup (build 9.0.21022.08) and followed additional tip here:
http://www.codeplex.com/IronPythonStudio/Thread/View.aspx?ThreadId=18975

VS2008 is installed in C:\VS 2008 Shell Redist\Isolated Mode and the Add/Remove confirms it is installed (I also rebooted the PC).

When I launch a DOS shell with admin rights and cd to IronPythonStudio folder to do a """msiexec /i IronPythonStudio.msi"""" I have a message box saying that the Visual Studio Shell 2008 Isolated Mode Redistributable package is required.

I've added C:\VS 2008 Shell Redist\Isolated Mode to my Windows Path, relaunched the Shell Dos, but it doesn't help either.

Help, please...

Dec 15, 2007 at 2:29 PM
Make sure you do the following in this link: http://msdn2.microsoft.com/en-us/library/aa367561.aspx

Here's what I had to do to get it working:

1) uninstall IronPython Studio
2) made change shown in link using regedit, I also used a dword 32 for the setting - b/c the key & setting in the link above wasn't in my reg and I had to manually add it
3) rebooted
4) reinstalled IronPython Studio, start it up

I'm running vista ultimate btw, I was also admin on my box.

- Scott
Dec 15, 2007 at 3:43 PM
Thanks Scott for your answer that I've just seen.
In fact just installation worked few minutes ago while messing around.
What I did was the following (there's probably lot of steps which are not necessary):
- re-downloaded the VS shell isolated (in case of file corruption)
- installed Visual Studio C# express. Even I know there shouldn't be any relations (I didn't have any version of VS installed)
- executed the VS shell isolated setup with admin privileges (right click menu) and installed it here: C:\VS 2008 Shell Redist\Isolated Mode
- went to that folder after "installation" and right clicked on vsshellisolated.enu.exe to run it with admin privileges
(this time after waiting 5 minutes Vista proposes me to install stuff in C:\Program Files\Microsoft Visual Studio 9.0 and I wonder if it's thanks to VS C# express prior install, don't know)
- run Dos shell with admin privileges, cd to Iron Python Studio Folder and did the "msiexec /i IronPythonStudio.msi" command
That worked :)

I've followed the screencast to see if everything was fine (just reproducing what is shown in the screencast):
- console application: Yes! :)
- windows applications: Yes! :)
- WPF applications: Didn't work, same message error as the one already reported by Fuzzyman : """ Unknown build error, 'Object reference not set to an instance of an object.' C:\Windows\Microsoft.NET\Framework\v3.5\Microsoft.WinFX.targets"""
http://www.codeplex.com/IronPythonStudio/Thread/View.aspx?ThreadId=19069

Anyway I'm already very pleased to be able to make Windows application in a visual way with this flavor of Python. I guess this will justify for me to learn Iron Python.

When the WPF part will work it will be cherry on the cake :)

PS: Interesting this move from Microsoft with the VS shell isolated:
http://www.regdeveloper.co.uk/2007/06/09/vs_shell_eclipse/
Jan 3, 2008 at 1:16 AM
I had the same problem too, and I have Vista Home Premium, but all you need to do is install the VS shell isolated, then go to the folder where you installed it, and run the application. Finally, just install the IronPython Studio through the command line.